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Creating Accessible Documents

When you create documents—regardless of the program you are using—it is essential to ensure that people
with disabilities can process them. All digital content and external documents (HTML, PDFs, Word, graphics,
images, efc.) published on any UB website and attached to any email must meet WCAG 2.1 AA accessibility
standards by April 24, 2026, which allows screen readers or other assistive devices to read the files properly.
This holds true whether the item is publicly available or served behind a firewall, such as Shibboleth.

Although it is possible to remediate digital content and external documents after they have been created, it is
strongly recommended to address accessibility in the source documents and files as you create them.

The following standards will help increase the accessibility elements of digital content and external documents.

e Use headings.
e Use lists.

e Add alternative text to images.

e Use tables appropriately and effectively.

e Write descriptive link text.

e Set document language.

e Set document properties.

e Understand how to export to PDF while preserving accessibility.

Headings

Use a hierarchical heading structure in your web documents. Proper headings convey content structure and form
an outline of the page content similar to a written report, news article or academic paper. Do not attempt to
achieve this form of outline through text size and font weight. Stylistic changes alone do not provide the
document structure required by assistive technology.

Six levels of headings, sequentially ordered, convey higher and lower levels of content hierarchy:

e Heading 1: usually a page title or a main content heading.

e Heading 2: usually a major section heading.

e Heading 3: usually a sub-heading smaller than H2. You can continue to make sub-headings
represented by H4, H5 and H6.

1. Each document must start with a heading level 1 and can only contain one heading level 1.

2. You can use as many heading levels 2 through 6 (the lowest level is 5 in the UBCMS) as needed to
handle the outline.

3. Do not skip/ignore a level in the sequence.

Example of a compliant Example of a noncompliant Example of a noncompliant
accessible heading structure: accessible heading structure:  accessible heading structure:
Heading 1 Heading 1 Heading 1
Heading 2 Heading 1 Heading 2
Heading 3 Heading 4
Heading 4 Heading 3

Heading 4
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Microsoft Word

1. Select the text you want to use as a heading. At the very minimum, there must be a
primary heading (H1) on every PDF file created. Therefore, at the minimum, the title of
the document must be tagged with the Heading 1 style. Bold and increased font looks
like a header, but those format changes do not create a tag in the final PDF file.

2. On the Home ribbon, select the heading style you want to use. You can see what it
looks like if you hover over the style.

3. To see additional styles, click the down arrow to expand the options available.

4. To modify an existing style, expand the styles window and select Manage Styles. To
add a new style, expand the styles window and select New Style. (Additional help with
managing and adding styles in Microsoft Word.)

Lists

Lists add important semantic and hierarchical structure to your documents. There are two types of lists:
ordered and unordered.

Use ordered lists to present a group of items that follow a sequence and usually include numbers. For
example:

1. Complete orientation data form.
2. Submit immunization records.

3. Register for classes.

4. Aftend orientation.

Use unordered lists to present a group of bulleted items that do not follow a sequence. For example:

e Time management.
e Test taking.
e  Study skills.
e Academic planning.

Use the bullet or numbering tools in your document to create lists. Simply indenting a list does not
provide the necessary document structure, making it more difficult for screen reader users to
understand.

Alternative text for images

Alternative text (aka, “alt text”) is a non-visual representation of the content or function of an image. All
images must have alt text.

According to WebAIM, alternative text serves several functions:

e |fis read by screen readers in place of images.

e [tisdisplayed in place of the image in browsers if the image file is not loaded or when the user
has chosen not to view images.

e |t provides a semantic meaning and description to images that can be read by search engines.


https://support.office.com/en-us/article/customize-or-create-new-styles-in-word-d38d6e47-f6fc-48eb-a607-1eb120dec563
https://support.office.com/en-us/article/customize-or-create-new-styles-in-word-d38d6e47-f6fc-48eb-a607-1eb120dec563
https://webaim.org/techniques/alttext/
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Writing alternative text can be a bit of an art but it is not impossible. Follow these tips when writing your
alt text:

e Provide meaningful information about what is in the image and accurately describe the
purpose of the image to the user.
e Ifthe image is also a link, summarize the function of the link in the alf text.
e Include any text that is in the image in the alt text.
o However, wherever possible, refrain from using images with text.
e Avoid using words like “photo of” or “image of” in your alt text.
e Ask yourself what you would want to know about the image if you could not see it.

Decorative images (i.e., bullets, icons, background images, etc.) are images that provide no added
context to the webpage or document. In such cases, decorative images do not require descriptive alt
text but do require null alt text, published as empty content using double quotes with nothing inside **
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or alt="".

Microsoft Word

Add your image to the document.

Right click the image.

Select Format Picture.

Click the icon for Layout & Properties and select Alt Text.

Add your full alt text in the Description field (or for a decorative image only, type ).
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Microsoft PowerPoint

Add your image fo the document.

Right click the image.

Select Format Picture.

Click the icon for Size & Properties and select Alt Text.

Add your full alt text in the Description field (or for a decorative image only, type ).
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Note: Unless you have a complex chart, you will usually want to enter text in just the Description box.
When you have complex content to describe, then filling in the Title field is useful so reading the full
description is not necessary unless desired.

It is also recommended that you modify your alt text on your first slide of a PowerPoint presentation
before you copy it multiple times. Each instance of an image needs to be tagged in a PDF file. You can
save fime tagging your decorative elements right away!

Additional help with adding alt text in other versions of Microsoft products.

Tables

Use tables solely to organize information and display relationships between data. Avoid using tables
for layout purposes and strive to make your tables as simple as possible. If you have a complex set of
data to display, consider creating more than one table.

Use the built-in table tools in your program to create tables.


https://support.office.com/en-us/article/add-alternative-text-to-a-shape-picture-chart-smartart-graphic-or-other-object-44989b2a-903c-4d9a-b742-6a75b451c669
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Microsoft Word

1. Click Insert > Table and move your cursor over the grid to select the number of
columns and rows you want.
2. ldentify the row that contains the column headers:
a. Select the row (Table Tools > Select > Row).
b. Right click the row and select Table Properties.
c. Click the Row tab.
d. Check the checkbox that says "Repeat as header row at top of each page”.

Links

When you include links tfo websites in your documents, write link text so it makes sense to users. Link text
should be descriptive enough that it can stand on its own. Avoid the use of phrases like “click here,”
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‘learn more,” "here,” “more,” “link to,” etc. Also, avoid using the URL of a webpage as the link text.

Instead of:  “Use this link to view our academic programs.”

Write: “Explore our academic programs.”

Instead of: “Click here for a list of academic advisors”

Write: “Find your advisor in the academic advisor directory.”

Instead of:  "Visit our website at https://www.buffalo.edu/cpmc/about/experiential-
learning-award/experiential-learning-award-application.html to apply for
the scholarship.”

Write: ‘Apply for the Experiential Learning Award.”

Document language

Every document must have a language specified so assistive technology knows what language to read
itin.

Document properties

Document properties, also known as metadata, are details about the file that describe or identify it.
Every PDF requires a minimum set of document properties. Similar to other elements of accessible
documents, it is most efficient to set your document properties in the source document prior to
converting to a PDF.

Microsoft Word

1. Click File tab.
2. On the Info screen, you will see Properties in the right column.


https://catalog.buffalo.edu/academicprograms/
https://catalog.buffalo.edu/academicprograms/
https://www.buffalo.edu/studentsuccess/advising.html?utm_source=from-404-pagenotfound-on-former-advising-site&utm_medium=redirect&utm_term=2024-10-30
https://www.buffalo.edu/studentsuccess/advising.html?utm_source=from-404-pagenotfound-on-former-advising-site&utm_medium=redirect&utm_term=2024-10-30
https://www.buffalo.edu/cpmc/about/experiential-learning-award/experiential-learning-award-application.html
https://www.buffalo.edu/cpmc/about/experiential-learning-award/experiential-learning-award-application.html
https://www.buffalo.edu/cpmc/about/experiential-learning-award/experiential-learning-award-application.html
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3. Click on "Show All Properties” at the end of the right column.
4. Complete the following information:
o Title: This is the title of the document.
o Tags: Include keywords about the subject of the document.
o Subject: Include a brief description of the document, being careful not to repeat
the title.
o Company: This should always be University at Buffalo.
o Author: This should not be an individual person’s name. Instead, this filed should
say University at Buffalo and include your department name. For example,
“University at Buffalo Office of the Registrar’.

Microsoft Publisher

1. Click File tab.

2. On the Info screen, you will see Publication Properties in the right column.

3. Click the down arrow next to Publication Properties and select Advanced Properties.
4. Click on the Summary tab and complete the following information:

o Title: This is the title of the document.

o Subject: Include a brief description of the document, being careful not to
repeat the title.

o Author: This should not be an individual person’s name. Instead, this filed
should say University at Buffalo and include your department name. For
example, “University at Buffalo Office of the Registrar”.

Company: This should always be University at Buffalo.
Keywords: Include keywords about the subject of the document.

PowerPoint

We never recommend posting a PowerPoint file on a website. In the event you absolutely
need to post a slideshow, you should convert it to a PDF prior to posting.

Converting to PDF

When you create a PDF from your source document, you must ensure that you preserve accessibility
and ensure that your PDF is tagged. Tags in PDFs provide a hidden structured, textual representation
of the content (WebAIM).

Many PDF files start as Microsoft Word documents. Microsoft Office provides tools to create accessible
PDFs, provided that your original document is accessible.

Please note: Never print to PDF. Doing so does not preserve the document’s accessibility features.

Microsoft Word 2013 and 2010

1. Go to File > Save As Adobe PDF.
2. Select Options in the save screen and check the following:

a. Convert document information.

b. Enable Accessibility and Reflow with tagged Adobe PDF.
3. Name your file and save it.


https://webaim.org/techniques/acrobat/
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Evaluate PDF Accessibility

Microsoft added an Accessibility Checker that you can use to review your files before you save as a
PDF. You can either search for the phrase or find it under the Review tab. They are updating this tool
regularly.

After you create your PDF, take some time to evaluate the accessibility of your PDF using Adobe
Acrobat DC. You can use Adobe Reader minimally to verify that the document properties have been
saved to the PDF, but the best way to evaluate and enhance the accessibility of your PDF is by using
Adobe Acrobat DC.

1. Choose Tools > Accessibility.

2. Inthe secondary toolbar, click Full Check.
In Report Options, select options for how you want to view the report. You can save the results
as an HTML file or attach the results to the document.

4. Select one or more of the Checking Options. We

suggest selecting all of the options under each Accessibility Checker X
category (Document; Page content; Forms, Tables and
Lists; and Alternate Text and Headings). E

5. Click Start Checking.

6. The resulting report will display the status of each of
the accessibility rules checked. « Accessibility permission flag - Passed

o Image-only PDF - Passed

~ Document (5 issues)

e A green check mark means your document
passed that rule. € Tagged PDF - Failed

. . {g) Logical Reading Order - Needs manual check
e You will have to manually review and

correct/pass rules with blue question marks. € Primary language - Failed

Title - Failed
Red Xs are errors. You must fix each of these in order to have a @ *

fully accessible PDF. «# Bookmarks - Passed

@ Color contrast - Meeds manual check

Additional resources

The Accessibility at UB website.

Siteimprove is the university’s subscription service for website content auditing and accessibility
checking. If you are not currently a subscriber to Siteimprove for your website, please submit a work
order to request an account.

If you prefer to have the university’s PDF Remediation vendor make your document accessible, contact
GrackleDocs for a free quote. SUNY has contract pricing with GrackleDocs, so be sure fo mention you
are affiliated with SUNY University at Buffalo.

Marketing, Communications and Digital Engagement offers a variety of training courses to Academic
Affair's staff that include best practices and "how to’s” relating to accessibility. If you have not yet
attended one of our courses or you want a refresher, please register for an upcoming session.



https://www.buffalo.edu/access/services.html
https://ubuffalo.atlassian.net/servicedesk/customer/portal/4/group/9/create/73
https://ubuffalo.atlassian.net/servicedesk/customer/portal/4/group/9/create/73
https://www.grackledocs.com/en/
https://www.buffalo.edu/academicaffairs/mcde-training-classes.html

